[Bioclusters] SGE on Mac OS X

Chris Dagdigian bioclusters@bioinformatics.org
Mon, 19 Apr 2004 12:34:25 -0400

I use SGE on OS X all the time and run it constantly on my powerbook. 
The only thing that does not work for me with sge 5.3p6 is the qmon X11 
app. No time to debug that yet - I'll probably have to ask the SGE dev- 
list for help.

Chris -- it seems if you are having basic installation issues. Most of 
the time this is caused by odd hostname resolution issues but there can 
also be other causes for failed installations.

The OS X install is the same process as the Unix install. There is no 
real difference except sometimes you have to jump through some hoops to 
get the sge daemons to start properly on boot time.

The most useful thing for us on this list to help you out would be a 
cut-and-paste of your installation attempt that specifically shows us 
what you were typing and what the errors were that came back.

Without knowing exactly what happened (and where in the install/setup 
process it occured) we can't be of much help.


Chris Iacovella wrote:

> My specific goal is to have a headnode that I can submit jobs to, and 
> have the headnode send out the jobs to the available nodes in the cluster.
> The request for a tutorial would be regarding the proper installation 
> procedure for setting up a simple cluster for mac os x (between machines 
> that all have static IPs, all hooked into the same switch).  Following 
> the standard install to the best of my ability, has not led to a 
> properly functioning cluster.
> Chris
> On Apr 19, 2004, at 11:45 AM, Rayson Ho wrote:
>> It's not difficult to install SGE at all, I think you should tell us
>> what you are encountering, rather than us guessing or writing a
>> tutorial for you.
>> I've been using SGE on OSX for more than a year, on a 28 CPUs cluster.
>> More than 100000 jobs were handled by it.
>> Rayson
>> --- Chris Iacovella <cri@umich.edu> wrote:
>>> I've been having issues getting SGE working properly on the small
>>> cluster of power Mac G5's (running 10.3.3) in my lab (it works fine
>>> on
>>> one machines, but as a cluster, it doesn't work correctly).  It would
>>> be very useful if,  someone that has successfully installed SGE on
>>> MacOS X, could  write up a tutorial specifically for macs.
>>> Thanks,
>>> Chris Iacovella
>>> _______________________________________________
>>> Bioclusters maillist  -  Bioclusters@bioinformatics.org
>>> https://bioinformatics.org/mailman/listinfo/bioclusters
>> __________________________________
>> Do you Yahoo!?
>> Yahoo! Photos: High-quality 4x6 digital prints for 25
>> http://photos.yahoo.com/ph/print_splash
>> _______________________________________________
>> Bioclusters maillist  -  Bioclusters@bioinformatics.org
>> https://bioinformatics.org/mailman/listinfo/bioclusters
> _______________________________________________
> Bioclusters maillist  -  Bioclusters@bioinformatics.org
> https://bioinformatics.org/mailman/listinfo/bioclusters

Chris Dagdigian, <dag@sonsorol.org>
BioTeam  - Independent life science IT & informatics consulting
Office: 617-665-6088, Mobile: 617-877-5498, Fax: 425-699-0193
PGP KeyID: 83D4310E iChat/AIM: bioteamdag  Web: http://bioteam.net