[Bioclusters] MPI environment

ankit patel ankitpatel_259 at yahoo.co.in
Mon Oct 30 03:52:16 EST 2006


Instead of startmpi.sh in lam-mpi you have to give lamboot and stopmpi.sh you have to use lamhalt. which are at /usr/local/bin/ directory.

"Per Jr. Greisen" <pgreisen at gmail.com> wrote: Hey,
 I am new to clusters and hope that it is okay for me to pose a questions here. I have tried to submit a program which should be executed parallel but as I submit it - it only runs on one processor. First I used the chm-parallel environment which is default at this cluster. Than I tried to change the parallel environment to mpi and use mpirun but it gave me the error-message that it couldnt find the mpi environment. 
 I have used the mpirun on the "helloworld.c"-program and when executed alone it returns from the specified notes. 
 When I go to opt/sge - both the chm and mpi environment are there - how can I enforce it to use the mpi environment? - Given the full-path and to which file in the directory? (there is a startmpi.sh ?)
 Thanks in advance
 Best regards
Bioclusters maillist  -  Bioclusters at bioinformatics.org

With Warm Regards,

Ankit Patel
 Find out what India is talking about on  - Yahoo! Answers India 
 Send FREE SMS to your friend's mobile from Yahoo! Messenger Version 8. Get it NOW
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://bioinformatics.org/pipermail/bioclusters/attachments/20061030/69e6b6fe/attachment.html

More information about the Bioclusters mailing list