[Bioclusters] mpi BLAST installation problem

Dan Swan bioinformatics.lists at gmail.com
Thu May 3 04:27:16 EDT 2007

On 5/2/07, sangamesh chowdappanavar <sangameshbc7 at yahoo.co.in> wrote:
> Hi,
>       I am getting the error in the installation of mpiBALST-1.4.0 and ncbi.  Patching of mpiBLAST with ncbi is ok. next step is > ncbi/make/makedis.csh.
>  It is giving the error as follows:
> ....
> .....
> Fatal error building NCBI core libraries.
> Please be sure that you have X11 and Motif libraries installed.
> The NCBI toolkit FAQ at ftp://ftp.ncbi.nih.gov/toolbox/FAQ.html may be helpful.
>     I have referred all the installation guides, but still i am not getting. Please help me to proceed.

Well the first question is really - do you have X11 installed on the
system (Xwindows)?  The failure message is quite straightforward.  The
NCBI toolkit is missing some dependencies it needs  to compile.

Knowing what OS you were attempting to install on would also help.

You apparently also need the Motif libraries
(http://www.opengroup.org/motif/), although you might be interested in
one of the more liberally licenced versions (OpenMotif:
http://www.opengroup.org/openmotif/ or LessTif

If you're running on something like RedHat then you will be able to
find rpm packages of these to satisfy your needs.



Research Support Officer, Bioinformatics Support Unit,
Institute for Cell and Molecular Biosciences,
Faculty of Medical Sciences, Framlington Place,
Newcastle University, Newcastle, NE2 4HH
Tel: +44 (0)191 222 7253  (Leech offices: Rooms M.2046/M.2046A - Mon/Wed)
Tel: +44 (0)191  246 4833 (Devonshire offices: Rooms G.25/G.26 - Thu/Fri)
Website: http://bsu.ncl.ac.uk/

More information about the Bioclusters mailing list