[Biococoa-dev] Base test
jtimmer at bellatlantic.net
Sat Aug 14 17:40:36 EDT 2004
Quick naming ideal - how about BCSequenceUnit as the root class of bases and
amino acids? Then BCSequenceUnitDNABase, BCSequenceUnitAminoAcid, etc.
The problem I have with the name "symbol" is that the items the classes will
be representing have symbols, and so will have a symbol variable and a
symbol method, so it's a bit of circular nomenclature.
Incidentally, I'm not going to implement the base class just yet (even if we
did know what we're calling it) - I'll get the DNA bases working first and
then figure out which methods would also apply to an amino acid and move
them up the inheritance chain.
I've also attached the preliminary .plist file I'll be using to generate
base definitions. Let me know if I made any mistakes, and feel free to add
any other bases if you have time to kill.
My current thought on extensibility:
The class will have singleton variables and methods for accessing all
defined bases, and I'll go looking through the .plist file for them. Any
additional items will get held in a "custom base" dictionary, and will be
accessible through a "getCustomBase: (NSString *)baseName". This will allow
for quick access for typical uses, but still provide flexibility.
I'm diving into this now, so stop me if I'm making a stupid mistake...
This mind intentionally left blank
-------------- next part --------------
A non-text attachment was scrubbed...
Name: base template.plist
Size: 4503 bytes
Desc: not available
More information about the Biococoa-dev