[Biococoa-dev] Base test

Alexander Griekspoor mek at mekentosj.com
Mon Aug 16 06:02:29 EDT 2004

>> The naming scheme first, I understand the possible clash with the use 
>> of Symbol, although I think it still represents the subject best, and 
>> we are talking about BCSymbol instead of symbol (can't we call this 
>> latter property "character" (biojava calls them "token" which is a 
>> nice name as well).
> BCSymbol implies only a symbol, not a whole subunit of a sequence, 
> including all associated data.
I don't really see why it wouldn't, but maybe that's indeed what it did 
become in our case.

>  I still like BCRoot or BCUnit (both only 6 charatcters, so not much 
> to type :)
Personally: BCRoot is too heavy and doesn't sound like having to do 
anything with sequence units, and almost like a super super class 
everything derives from (like NSObject).  BCUnit, hmm I you persist ok, 
but still something in me doesn't like that either.
Why don't we pick BCToken? Or call the unit BCSymbol and what we call 
symbol now, a token, like BioJava does....
Again, if you are all in favour of BCUnit, that's ok.


                     ** Alexander Griekspoor **
               The Netherlands Cancer Institute
               Department of Tumorbiology (H4)
          Plesmanlaan 121, 1066 CX, Amsterdam
                   Tel:  + 31 20 - 512 2023
                   Fax:  + 31 20 - 512 2029
                   E-mail: a.griekspoor at nki.nl
	        AIM: mekentosj at mac.com
               Web: http://www.mekentosj.com

                  EnzymeX - To cut or not to cut


More information about the Biococoa-dev mailing list