[Biococoa-dev] more ramblings
Koen van der Drift
kvddrift at earthlink.net
Thu Dec 2 21:05:08 EST 2004
On Dec 2, 2004, at 2:02 AM, Alexander Griekspoor wrote:
> The basic setup is something we all agree on I think, it would be nice
> indeed if all classes had the same BCSequence prefix, although not
> easy ;-) I like BCSequenceBundle, but I'm not sure if wrapper is
> appropriate. I know we consider it a wrapper object, but I would like
> to keep it closer to sequences, I thought of BCAnnotatedSequence, but
> it would loose the common prefix. Still, better than
> BCSequenceWrapper. Anyway, the (semi-)native englishmen on this list
> can jump in here ;-).
Hey, I'm semi-native american!
> Wait, would it be an idea to make it:
> BCAnnotatedSequenceBundle - a bundle of BCAnnotatedSequences (in an
> BCAnnotatedSequence - contains a dictionary of BCFeatures (so no
> BCFeatures object, because that has no advantage over a dictionary), a
> BCSequence, a dictionary of BCAnnotation
I like the BCAnnotatedSequence name. Although it kinda leaves out the
BTW, I'm still confused about what is the difference between a feature
and an annotation. I think we should define very well what we want to
store in either one. And if the BCFeature and BCAnnotation aren't
objects, what do you intend them to be?
Should we also make a special class BCAnnotatedSequenceReader that
takes care of extracting as much as info as possible from a file? Or
should we do everything with BCSequenceReader.?
>> Actually, I think that is a good point. But we have to be aware of
>> the fact that a developer can have all compiler warnings turned off.
> Then it's a stupid developer IMHO....
Yep - and we all know there's plenty of them ;-)
More information about the Biococoa-dev