[ghemical-users] Cannot find blas library needed for MPQC support

Javier fjljara at ugr.es
Fri Mar 7 16:22:26 EST 2008


	I am installing ghemical.2.95 under linux suse 10.0.  I have installed
blas library (atlas3.6.0) at /usr/local/lib/atlas and I have got the
following *.a libraries:
 
libatlas.a  libcblas.a  libf77blas.a  liblapack.a  libtstatlas.a


Afterward the installation of mpqc-2.3.2 and mopac7-1.13 have gone
smoothly.  However, the installation of the libghemical package
(libghemical-2.95) with "--enale-mpqc" has died with the message:

----
checking how to hardcode library paths into programs... immediate
checking for ar... /usr/bin/ar
checking for sh... /bin/sh
checking whether make sets $(MAKE)... (cached) yes
checking whether build environment is sane... yes
checking for acos in -lm... yes
checking for main in -lblas... no
configure: error: Cannot find blas library needed for MPQC support
---

When I have checked the log file and found:
 
---
configure:19319: gcc -o conftest -g -O2   conftest.c -lblas  -lm  >&5
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../libblas.so: undefined
reference to `e_wsfe'
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../libblas.so: undefined
reference to `z_abs'
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../libblas.so: undefined
reference to `do_fio'
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../libblas.so: undefined
reference to `s_stop'
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../libblas.so: undefined
reference to `c_abs'
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../libblas.so: undefined
reference to `s_wsfe'
----

It seems that it is trying to link to an older libblas.so file that I
have in a different directory in order to run CCP4 (crystallography
software).  

I would be very happy for any suggestion.
Best regards,

			JAVIER
 





More information about the ghemical-users mailing list