[Owl-devel] suggestions for updating the package structure in OWL

Dan Bolser dan.bolser at gmail.com
Fri Mar 19 09:57:11 EDT 2010

I'm an outsider here, but just my 2c... OWL also stands for 'Web
Ontology Language' (a so-called dyslexic acronym). Most ontologies in
biology are written in the OBO format, however, there is a push to
move towards the more standard OWL format for biological ontologies.
For this reason 'owl.protein' may not be the best name for your

Just something to consider - it may not be an issue at all.

All the best,

On 19 March 2010 10:13, Henning Stehr <stehr at molgen.mpg.de> wrote:
> Dear developers,
> since we are currently rearranging some stuff in OWL which always
> makes it necessary to
> update imports and calls in other projects, maybe its a good time to
> think about the package
> structure in general to make OWL fit for the future.
> So here are some suggestions for changes to the package structure in OWL:
> Minor changes:
> - move all SomethingRunner classes from owl.proteinstructure and
> owl.sequence to owl.runners
> - create a subpackage owl.runners.blast and move all Blast related stuff there
> - move owl.tinker to owl.runners.tinker and create owl.runners.gromacs
> for gromacs stuff
> - create a subpackage proteinstructure.graphs and move all RIG and AIG
> related stuff there
> - maybe create proteinstructure.graphs.rigs and proteinstructure.graphs.aigs
> Major changes:
> - make a root package 'owl' and move everything there, i.e.
> owl.proteinstructure, owl.sequence, ...
>  this would be clearer and prevent name conflicts with other
> libraries which may also contain e.g. a 'sequence' package
> - currently there are two types of packages:
>  1. those containing collections of basic classes such as sequence,
> proteinstructure, features, connections, runners and
>  2. those containing essentially independent projects such as casp,
> deltaRank, embed, sadp.
>  Suggestion: Create a package owl.core and move all packages from 1.
> there. The basic idea would be that 'core' should
> be stuff that is used by many projects and 2. stuff that is more for a
> specific usecase
> - if we do the above, owl.proteinstructure.decoyScoring should be
> moved to owl.decoyScoring
> As you can see some of these are more long term plans but maybe it's
> less painfull to do it all together so that hopefully
> the package structure can remain stable for a while.
> For the moment, I won't do anything, but what do you think about these
> changes? We can dicuss later when would be
> a good time to actually do it.
> Henning
> _______________________________________________
> Owl-devel mailing list
> Owl-devel at bioinformatics.org
> http://www.bioinformatics.org/mailman/listinfo/owl-devel

More information about the Owl-devel mailing list