[Pipet Devel] Gnome 1.2 and Overflow

jarl van katwijk jarl at casema.net
Fri May 26 21:45:01 EDT 2000

> <stupid_american_remark>
> Well, why would anyone ever want to run in a non-english locale? :-)
> </stupid_american_remark>

`killall -9 --gid=usa`

> > For me (I use the french locale), the floating
> > point numbers are printed and parsed with a "," insteat of a ".",
> which
> > breaks
> > everything. This affects C++ streams. I don't know whether the
> printf and
> > scanf
> > are affected. The only way around is to unset the language
> environment
> > variables.
> I don't know how stable 1.2 is supposed to be (it's still in the
> preview stage, right?) but I would report this. It seems like they are
> very for supporting internationalization, so they would probably be
> quite iterested to hear about this problem.

gtk 1.4 will get fill i18n support; gnome being build on top of gtk 1.2 will
keep having non-100% locale support :(
My personal opinion is alien languages like dutch should be low priority.

sorry bout being not really constructive,

More information about the Pipet-Devel mailing list