[Biococoa-dev] Should we choose?
Koen van der Drift
kvddrift at earthlink.net
Wed Jan 12 18:31:40 EST 2005
On Jan 12, 2005, at 1:41 AM, Charles PARNOT wrote:
> Wow, it looks like we get a nice unanimous agreement! I guess I will
> have to write the (very little) code needed for BCSequenceGeneric, now
> that I bragged so much about it. BTW, is the naming OK? I was tempted
> to propose simply BCSequence for the generic subclass, but I think in
> the end, BCSequenceGeneric (or something equivalent) could carry more
> sense and be clearer for everybody, particularly if living with other
> subclasses. And keeping the superclass name to BCSequence is also more
> consistent with the class hierarchy. OK, I know, I am just arguing
> with myself, here.
Actually, I would prefer the name BCSequence for what the user will
use, which is BCSequenceGeneric in your proposal, right? We can then
rename BCSequence to something like BCAbstractSequence, or even promote
the current BCSymbolList to that role.
> Next issues are:
> * annotations (a new ivar in the superclass, and a category of the
> superclass for the implementation??)
IIRC, I think we already agreed to make a BCAnnotation class, and put
an ivar to it in the superclass.
More information about the Biococoa-dev