[Biococoa-dev] Displaying protein sequences and alignments in a NSTextView

Koen van der Drift kvddrift at earthlink.net
Sat Jun 13 18:45:07 EDT 2009

Dear Peter,

Thanks for your message. I will try to answer your questions. I also  
CC'ed the mailinglist so other developers get a chance to respond.

> I am tinkering a bit with adding GUI front ends to some of my own  
> scripts as well as bioinformatics command-line tools using NSTask,  
> and the basic machinery now works. Then there is the task of  
> displaying protein sequences in a nice way and here I have just  
> found out that NSTextView cannot easily me made to not  wrap the  
> lines. I have found various work-arounds rather than good solutions  
> for this by Googling, so rather unhappy about it I now think that I  
> should go all the way as you have done in Biococa 2.
> Firstly, I suppose that your NSTextView will allow for a non- 
> columnar view as is used for (aligned) protein sequences?

That should be possible, right now the BCSequenceView is only included  
as an example and is not very flexible. You could subclass it to add  
the text display behavior that you are looking for.

> Secondly, I wanted to take a look at one of your examples and chose  
> Peptides. I created a new project in XCode, threw out plists that  
> were already in the Peptides example as well as the main menu nib  
> and replaced it with the files of the example. Added the Biococoa2  
> framework and hit "Build". Exit with status 5. This does not mean  
> anything to me, I am sorry to say.

I get the same error too, it looks like the project is missing a build  
phase. This is how you can solve it:

In Xcode, open the Targets in the left column, and right-click on  
Peptides. Then choose Add ->  New Build Phase ->  New Copy Files Build  
Phase. This will add an extra gray rectangle under Peptides. Look  
again in the left column, open Frameworks and drag the BioCocoa icon  
to the copy build phase you just added. You should now see the  
BioCocoa toolbox icon in both places. Now try to rebuild and run it.

Can anyone with svn commit access fix this in SVN, and maybe in the  
release that Peter is using?

> Thirdly I tried the command-line entries to build the documentation.  
> It does not work, no matter where I cd to. It invariably says  
> "HeaderDoc: file/directory not found: BCFoundation". What is it that  
> I do not get here? Why not just include the html-files themselves  
> rather than these extra hoops to jump through?

Building the documentation from Xcode does not give me any errors with  
the most recent realeae of BioCocoa on my system. BioCocoa uses  
Headerdoc to generate the docs, so comments in the code will be  
converted to html.

> So basically I have to admit that probably is something quite basic  
> about BioCocoa that I have missed, and wonder if you would get me on  
> the right track?

Probably :) What system and BioCocoa version are you using?

Hopefully this answers some of your questions - feel free to ask more  
if thing are unclear.

- Koen.

More information about the Biococoa-dev mailing list