[Owl-devel] Question about code - readScoreMatsFromFiles
dan.bolser at gmail.com
Wed May 5 02:35:32 EDT 2010
It seems that the method 'readScoreMatsFromFiles' in the Scorer class
of the owl.decoyScoring package should be renamed to something like
'readTypeAndCountMatsFromFiles' ... or something similar.
My question is this, should I feel free to go ahead and rename
methods, with the intention that my commit will be reviewed, and,
where necessary, a sensible name will be picked (i.e. the method will
be re-renamed), or should I initiate a discussion about this change on
the mailing list (as above)?
I realise that it's impossible to legislate for every kind of edit,
but I'm new to Java and new to the code base, so I don't have a good
feel for what constitutes an insignificant, minor, significant
(annoying), or major change.
I tried to submit a change* which just added some comments, and I
found myself writing quite a lot in the commit message (to communicate
my intentions, but also asking some questions). Should I avoid putting
* (Although I didn't yet set up rw svn access).
More information about the Owl-devel