[Owl-devel] Question about code - readScoreMatsFromFiles
Jose M. Duarte
jose.m.duarte at gmail.com
Wed May 5 10:48:22 EDT 2010
On 5 May 2010 08:35, Dan Bolser <dan.bolser at gmail.com> wrote:
> It seems that the method 'readScoreMatsFromFiles' in the Scorer class
> of the owl.decoyScoring package should be renamed to something like
> 'readTypeAndCountMatsFromFiles' ... or something similar.
Agree.. that's probably a much better name! And by the way the java doc was
not quite right so I've committed a fix for it. I must say I wrote all this
code really quickly and I'm not very happy with much of it, especially with
the object model. I think introducing the new interface would make things
already a lot better.
> My question is this, should I feel free to go ahead and rename
> methods, with the intention that my commit will be reviewed, and,
> where necessary, a sensible name will be picked (i.e. the method will
> be re-renamed), or should I initiate a discussion about this change on
> the mailing list (as above)?
Well there's no good reply to that, it's based on feeling and experience as
you would guess. It's pretty much the same as with wikipedia editing or any
other type of crowd sourcing. For this case I wouldn't initiate a
discussion, I'd just do it.
> I realise that it's impossible to legislate for every kind of edit,
> but I'm new to Java and new to the code base, so I don't have a good
> feel for what constitutes an insignificant, minor, significant
> (annoying), or major change.
> I tried to submit a change* which just added some comments, and I
> found myself writing quite a lot in the commit message (to communicate
> my intentions, but also asking some questions). Should I avoid putting
> questions there?
Re commit comments what I tend to do these days is to describe what the
change is about in a brief way without going into the details of what exact
code/specific class/methods changed but rather giving an overview like: what
functionality changed, a certain bug was fixed, a refactoring and the
reasons for it etc. In my opinion sometimes it is important to be verbose
especially for certain bug fixes, code that break some compatibility and
that kind of thing. In any case if in doubt rather be verbose than not!
I'd say just take the plunge and experiment! By all means if you decide to
rename do use eclipse's refactoring tool. It will take care of all
interdependencies while refactoring plus it will warn you if something is
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Owl-devel