[Pipet Devel] new BL error

Jean-Marc Valin jmvalin at locusdialogue.com
Thu Mar 22 17:50:42 EST 2001

> Yes true, it's very hard to write multi compiler C++. And like Jean Marc
> mentioned, gcc 2.96 is related to the developement of gcc 3.00. I
> understand why you ask, you fear that 3.01 and so on will be a problem
> too. I exspect there'll be some issues with every release, but not as
> many as we'll face now.

What I've heard is that they made sure the gcc 2.95.x stays both source
and binary compatible, then they started a development branch, which
they called 2.96, which may break compatibility every day... towards
3.0, which should stay (source and binary) compatible for a while. You
can go to http://gcc.gnu.org to have the gcc team's opinion on RH
releasing a development compiler... Now, gcc changed the name of their
develoment branch to 2.97 to avoid confusion with the RH 2.96 compiler.

> Is this really true, did Redhand bundle a developement gcc with RH7?
> They are really trying hard to have people download binairy rpm's..

They say 2.96 is better (in their opinion) than 2.95.2, so they choosed
it. BTW, even binary RPM's don't work, because they're dynamically
linked with libraries that have a different ABI! So if you want to use
one of the Overflow rpm's I provided, you need to have the 2.95.x


More information about the Pipet-Devel mailing list